New site issues

This forum is meant for anything you would like to share with other visitors
ic2
Posts: 1804
Joined: Sun Feb 28, 2016 11:30 pm
Location: Holland

New site issues

Post by ic2 »

There are still a lot of thing not working in the current site. E.g.:

1 I often can not edit a post I posted earlier
2 A search often shows irrelevant or incorrect results. What I also saw once: I get many results and when I decide to check these page by page (it says 100's of results so dozens of pages), after pressing the arrow a few times I am at the end, skipping the most pages before it.
3 The lay out is confusing. The search button looks like nearly the same as the field in which you should enter the phrase to search
4 Assigning the Code tag or Quote often requires to go into the Source mode, otherwise it does not work correctly
5 A page often looks completely wrong, see the picture below (tried in 2 browsers). In this case the left part of the text is not visible, there is no scrollbar and a refresh doesn't fix it either.

 
XSharpsiteWrong.jpg
XSharpsiteWrong.jpg (47.19 KiB) Viewed 1688 times

I think keeping the old and clearly better working site, even with a no longer supported module for commenting, would have been a better idea.

Dick
User avatar
Chris
Posts: 4584
Joined: Thu Oct 08, 2015 7:48 am
Location: Greece

New site issues

Post by Chris »

Hi Dick,

In hindsight, of course I agree. But I don't think anyone could had guessed that a newer version would have so many problems, before updating to it..
Chris Pyrgas

XSharp Development Team test
chris(at)xsharp.eu
User avatar
robert
Posts: 4258
Joined: Fri Aug 21, 2015 10:57 am
Location: Netherlands

New site issues

Post by robert »

Guys,
There was really no option to stay with the old site. The Joomla version is no longer supported from August 17, 2023, which is today.
I think the biggest problem is in the forum. I am also not happy with it. That is why I am looking into an alternative.
It should be possible to embed PhPBB into our website using a component called p8pBB .

https://alterbrains.com/joomla-extensio ... pbb-bridge

Importing the existing messages may be a bit of work.
I'll set up a trial first, so our subscribers can test it.

Robert
XSharp Development Team
The Netherlands
robert@xsharp.eu
User avatar
wriedmann
Posts: 3655
Joined: Mon Nov 02, 2015 5:07 pm
Location: Italy

New site issues

Post by wriedmann »

Hi Robert,
is there any way to aument the ressources to this virtual machine? It seems it lacks memory or processing power...
Wolfgang
Wolfgang Riedmann
Meran, South Tyrol, Italy
wolfgang@riedmann.it
https://www.riedmann.it - https://docs.xsharp.it
User avatar
robert
Posts: 4258
Joined: Fri Aug 21, 2015 10:57 am
Location: Netherlands

New site issues

Post by robert »

Wolfgang,

I am working on this. Most likely in a the next week the forum will be replaced with phpBB and I am also looking into upgrading the VPS.
Our provider has dramatically increased the price without improving things, so there is also a financial motivation to change things.

Robert
XSharp Development Team
The Netherlands
robert@xsharp.eu
User avatar
wriedmann
Posts: 3655
Joined: Mon Nov 02, 2015 5:07 pm
Location: Italy

New site issues

Post by wriedmann »

Hi Robert,
if you need something like a container in our ProxMox cluster please let me know.
Wolfgang
Wolfgang Riedmann
Meran, South Tyrol, Italy
wolfgang@riedmann.it
https://www.riedmann.it - https://docs.xsharp.it
ic2
Posts: 1804
Joined: Sun Feb 28, 2016 11:30 pm
Location: Holland

Re: New site issues

Post by ic2 »

Hello Robert,
robert wrote: Tue Aug 22, 2023 7:55 pm I am working on this.
I reply here so I can see if the rest is working. What I don't see anymore is the "x messages, y new" in the summary. That was very useful to see what was actually new.

Could be because of the conversion, although I'd expect then the system to show all as new?



EDIT: seems to work. Quote also. Code too. Good!

Code: Select all

This could be code 
However: I attached a small picture. How do I insert it in the text? The image button only inserts this:
Image
And I couldn't even upload an attachment. There's an icon with an exclamation mark saying Sorry the board attachment quota has been reached.
Minor other remark is that Ctrl I etc doesn't work (I button does so no big issue)

Dick
User avatar
robert
Posts: 4258
Joined: Fri Aug 21, 2015 10:57 am
Location: Netherlands

Re: New site issues

Post by robert »

Dick,
For now, I have added a second module on the front page with "New Forum Messages".
And I have renamed the "Last Forum Messages" to "Recent Forum Messages".

You can also access the list of "new posts" from the "Quick Links" hamburger menu in the forum.

Robert
XSharp Development Team
The Netherlands
robert@xsharp.eu
ic2
Posts: 1804
Joined: Sun Feb 28, 2016 11:30 pm
Location: Holland

Re: New site issues

Post by ic2 »

Hello Robert,
robert wrote: Tue Aug 22, 2023 7:55 pm For now, I have added a second module on the front page with "New Forum Messages".
That seems to work indeed. Also the hamburger menu option to see all my posts (and some more new options) is very useful
I noticed that I clicked quot on your reply but I didn't see the "For now..." part in the quot. I manually added it. Perhaps because the reply also contained all the previous info and quots. But for now this looks like an improvement.

Only the confusing "Search" entry + button on the home page remain but this is only a very minor issue for which you shouldn't invest time I'd say.

EDIT: after I posted this issue Robert's answer looked clean again and the quot option now would have worked as it should.

Dick
leon-ts
Posts: 429
Joined: Fri Feb 03, 2017 1:43 pm

Re: New site issues

Post by leon-ts »

Hi,
On the main page of the site in the login area, the button opposite the password has a disproportionate size:
Screenshot.png
Screenshot.png (10.56 KiB) Viewed 1710 times
This is seen in Firefox and Edge browsers.
Best regards,
Leonid
Post Reply