Bad display of the Toolbox when editing a VO FORM on a 4k screen

This forum is meant for questions and discussions about the X# language and tools
Post Reply
AlainC
Posts: 10
Joined: Mon Nov 15, 2021 9:57 am

Bad display of the Toolbox when editing a VO FORM on a 4k screen

Post by AlainC »

Hi,
See attached image. Can you correct the problem? Thanks in advance.
Best regards
Attachments
Sans titre.jpg
Sans titre.jpg (59.52 KiB) Viewed 430 times
AlainC
Posts: 10
Joined: Mon Nov 15, 2021 9:57 am

Bad display of the Toolbox when editing a VO FORM on a 4k screen

Post by AlainC »

Maybe clearer in the zip file...
Attachments
Sans titre.zip
(180.93 KiB) Downloaded 40 times
ic2
Posts: 1804
Joined: Sun Feb 28, 2016 11:30 pm
Location: Holland

Bad display of the Toolbox when editing a VO FORM on a 4k screen

Post by ic2 »

Hello Alain,
AlainC post=23290 userid=6561 wrote: See attached image. Can you correct the problem? Thanks in advance.
The image is indeed unreadable but from the zip is is. Do you mean as issue that in the Toolbox the controls + description show only half?

This looks good on my X#. Is this in every project? What are your Windows /System, Display settings, e.g. Scale (is it 100%), Resolution?

Dick
AlainC
Posts: 10
Joined: Mon Nov 15, 2021 9:57 am

Bad display of the Toolbox when editing a VO FORM on a 4k screen

Post by AlainC »

Hello Dick,
> Do you mean as issue that in the Toolbox the controls + description show only half?
Yes
On every project.
My Windows / system : Windows 11, scale 150 %, resolution 3840 X 2160

If on this 28 inch 4k screen the scale is set to 1920 X 1080, the problem remains ! Even if I restart the system keeping this resolution. If I change the screen to a 24 inch 1920 x 1080, then the problem disappears.

Alain
ic2
Posts: 1804
Joined: Sun Feb 28, 2016 11:30 pm
Location: Holland

Bad display of the Toolbox when editing a VO FORM on a 4k screen

Post by ic2 »

Hello Alain,

And what happens if you have a 4K screen on 100%? I would expect the issue to appear on 4K systems with >100%. I have 1 4K monitor, 1 extra wide and 1 'regular' monitor (both HD) and for all I use 100% but I can read very small letters B)

I can move the toolbox to any of those 3 monitors; it gets smaller obviously on the 4K monitor but without disturbing the visibility.

Dick
User avatar
Chris
Posts: 4584
Joined: Thu Oct 08, 2015 7:48 am
Location: Greece

Bad display of the Toolbox when editing a VO FORM on a 4k screen

Post by Chris »

Hi Alain,

I guess that's due to the scaling used. Will look into this, thanks!
Chris Pyrgas

XSharp Development Team test
chris(at)xsharp.eu
AlainC
Posts: 10
Joined: Mon Nov 15, 2021 9:57 am

Bad display of the Toolbox when editing a VO FORM on a 4k screen

Post by AlainC »

Hi Dick,
Hi Chris,

With 100% scale (and 4k resolution) the problem persists for me. Maybe only with Windows 11 and not with Windows 10. Thanks !

Alain
User avatar
Chris
Posts: 4584
Joined: Thu Oct 08, 2015 7:48 am
Location: Greece

Bad display of the Toolbox when editing a VO FORM on a 4k screen

Post by Chris »

Hi Alain,

I could not reproduce this here unfortunately. Can you please post a (zipped) image of your screen settings when the problem still happens, as it could give an idea?
Chris Pyrgas

XSharp Development Team test
chris(at)xsharp.eu
ic2
Posts: 1804
Joined: Sun Feb 28, 2016 11:30 pm
Location: Holland

Bad display of the Toolbox when editing a VO FORM on a 4k screen

Post by ic2 »

Hello Alain,

Indeed I use W10 on 4K/100% and W11. Although W11 has a lot of issues, mainly Microsoft limited functionality and user adjustability, the scaling should not be too much different.

Do you see the correct screen & video card info when you click Advanced Display Settings?

Did you reset the Pc after going back to 100%?

Dick
AlainC
Posts: 10
Joined: Mon Nov 15, 2021 9:57 am

Bad display of the Toolbox when editing a VO FORM on a 4k screen

Post by AlainC »

Hi Chris and Dick,

Some tests: if the PC starts with the scale at 100% (and 3840 x 2160), then the ToolBox is normal. If right after I change to 150%, the ToolBox stays normal too. But if I restart the PC with the 150% then the problem occurs. We must therefore start with the scale at 150%.
My PC: Laptop LENOVO PC Yoga Slim 14ARE05 AMD Ryzen 7 4700U with a second Samsung 4K screen. See attached zip.
But do not waste too much time on this problem, we can live with it! Thanks

Alain
Attachments
pc.zip
(459.82 KiB) Downloaded 34 times
Post Reply